Techie
Yakuake ignoring Screen selection (Manjaro KDE)
by Logan Rogers-Follis on Mar.05, 2023, under Linux, Techie
Suddenly Yakuake (Manjaro KDE) would only open on the screen with the curios on it. When trying to force the Screen options it would just uncheck what I select and keep following the cursor. If I forced it’s location with Windows Rules it would go to the screen and location I want, but would act oddly.
This is a CONFIRMED bug 383555 with kde.org
Quick workaround was to set the Resolution Scaling to 100% and then it will work fine for me. Others have reported deleting certain files might also work.
HP Color LaserJet and Windows 10 HP Universal PCL6 driver not printing in color
by Logan Rogers-Follis on Oct.29, 2022, under Techie, Windows
This keeps changing on it’s own with my Windows 10 Pro computer and the HP Color LaserJet I have.
When the printer starts to print in Monochrome instead of color check the following:
- Right click the start icon and select Run.
- Type control and press OK.
- Open Devices and Printers.
- Right click the HP Universal Printing iocn and select Printer Properties.
- Open the Device Settings tab.
- Ensure the Device Type is set as Color rather than Auto Detect, confirm any changes by pressing OK.
Flatpak Thunderbird – How to fix attachments not working (Steam Deck Desktop Mode)
by Logan Rogers-Follis on Sep.29, 2022, under Linux, Techie
If you want to get Thunderbird on Steam Deck (Desktop Mode) to allow attachments then you need to run the following from Konsole:
sudo flatpak override org.mozilla.Thunderbird --filesystem=home
NOTE: You still can not use the Attach buttons or CTRL+SHIFT+A options, but click-and-drag works fine.
Blocking Roku (and other TV) Ads
by Logan Rogers-Follis on Jun.11, 2022, under Techie
History: Roku ads got annoying so I looked into blocking them. After reading multiple posts I was able to put together a complete solution for my setup.
First was to create a free account at NextDNS.io, then login and follow the directions to setup DoH on my router.
NOTE: The Mikrotik instructions are as follows (they offer instructions for most OS, browsers, and many routers):
/tool fetch url=https://curl.se/ca/cacert.pem
/certificate import file-name=cacert.pem
/ip dns set servers=
/ip dns static add name=dns.nextdns.io address=45.90.28.0 type=A
/ip dns static add name=dns.nextdns.io address=45.90.30.0 type=A
/ip dns set use-doh-server=“https://dns.nextdns.io/abcd1234” verify-doh-cert=yes
On NextDNS.io I added the following items:
- Privacy > Blocklists: Lightswight05 – Ads & Tracking
- Privacy > Native Tracking Protection – Roku, Samsung, Apple
- Denylist – *.wwwimg.roku.com
- Denylist – *.amoeba-plus.web.roku.com
NOTE: Once this was done you can see in the Logs that everything is was working. Looking at my Roku TV main screen, there was a blank area where the ads should be.
The last thing I did to make the most of this filtering was to add the following rules to my Firewall > NAT which ensures any device inside the network trying to access an external DNS server (via UDP/TCP port 53) was redirected to the router and through this DoH service:
/ip firewall nat add action=dst-nat chain=dstnat comment="dns redirector (udp)" src-address=192.168.1.0/24 dst-port=53 protocol=udp to-addresses=192.168.1.1
/ip firewall nat add action=dst-nat chain=dstnat comment="dns redirector (tcp)" src-address=192.168.1.0/24 dst-port=53 protocol=tcp to-addresses=192.168.1.1
Reference that I used to piece this all together:
https://jasonpearce.com/2020/09/16/how-to-disable-ads-on-the-roku-home-screen/
https://forum.mikrotik.com/viewtopic.php?t=133896N
Create file with full directly listing (Linux)
by Logan Rogers-Follis on Sep.06, 2020, under Linux, Techie
If you need a full listing of all the files in a folder saved to a file then use the following from a shell:
'ls' > file_list.txt
NOTE: In this case the file_list.txt file will be listed in the file_list.txt file, and to avoid this, just save the file_list.txt file to a different location than you are running the ‘ls’ command in.